Introduction
next

Fancy Fonts

Copyright 2015 by Hestor Ltd.
All Rights Reserved.
Fancy Fonts is a trademark of Hestor Ltd

We developed Fancy Fonts for our own internal use within our software applications, we have developed many applications over the years.

These range from simple stand alone systems, to systems in use within large organisations including Hospitals, etc.

Fancy Fonts will allow you to place a CAPTION / Lable like object on your form, the big difference is that three functions are made instantly available to you;

* Caption's can have a shadow behind it, the shadow going in one of eight different directions,

* Caption's can be flashing between colors at a given speed,

* Caption's can be set so once the user clicks it a web page is opened up in the default browser.

All of which is done by setting a simple properties.

* Shadow Color, Shadow Direction, Shadow Enabled, Shadow Width

* Flashing Color, Flashing Enabled

* Html Active, Html Link

Send your comments, suggestions or to ask questions about this component

Copyright 2015 - All Rights Reserved Hestor Ltd

© 2015 Hestor Ltd


Updates

Updates

Updates are automatically notified to all developers / registered user.

If you need any assistance or wish to ask any questions please email support@hestor.com


Getting Support

Getting Support

We want to be as helpful as possible. We always want you to come away happy. We realize that we can't make everyone happy (for some reason, our families believe we should be at home sometimes) we will however always help as best we can.

Help With Our Components

If you're having trouble with one of our components, here are a few general suggestions.

First, take a look at the sample programs. Usually, there is a sample program that shows how to

use every feature of our components. These can be quite helpful.

These sample programs are located in the default installation folders eg: c:\program files\hestor\Fancyfonts\Samples

Second, if you haven't already, take a look at the help file and/or manual.

They spell out what each of the Properties, Events, Methods, Objects and Interfaces does.

If you are still having trouble with one of our components, please feel free to contact us to get help.

When you do, make sure that you have as much information about your problem ready as possible.

The more you tell us, the better we can help you.

Help With General Programming

Many people come to us with questions about general programming issues. We would love to help everyone learn to become great programmers, but we simply don't have the time.

We would always suggest that you read books, try by example, take a look at someone else's coding, when buying books try the likes of ebay first, you can save a huge amount on books purchased that have already been used, and as a rule - as any developer will tell you - you only ever need just a chapter from a book - we personally have hundreds and hundreds of books in the office and the vast majority of them are secondhand !

Getting Support

You can receive support for our products from our FAQ, web site or e-mail.

This Help File

This help file is fully searchable. We suggest that you try that first before anything else. By searching in this help file, you'll be searching all of the reference information for this component and all of the FAQ questions and answers.

FAQ

You can find our FAQ at http://www.ocx.hestor.com/Faqs.html

E-Mail

If you cannot find the answer to your question on our web site, you can email us directly at support@hestor.com.


How to Purchase Licenses

© 2015 Hestor Ltd


Online Via Website
How to Purchase Licenses > Online Via Website

Online Via Website

You can purchase a full licence by visiting our website at the following address;

Fancy Fonts is sold as a single per developer OCX, this means each developer will require their own licence,.

As a good will gesture we will allow each developer to use their licence key for the OCX on both a fixed computer and their own laptop / notebook.

If you have any issues with registering your licence code or any other problems please contact us; support@hestor.com


Email / Telephone Direct
How to Purchase Licenses > Email / Telephone Direct

Email / Telephone Direct

We are always happy to help where ever possibly, you can send any questions or support issues via email to; support@hestor.com

We are based in the United Kingdom, support via telephone is offered between the hours of 9:00am to 5.00pm UK time.

You can call the support line on +44 (0) 161 660 1366


Legal Information

© 2015 Hestor Ltd


Royalty Free License Agreement
Legal Information > Royalty Free License Agreement

Royalty Free Licence Agreement

FancyFonts™ by Hestor Ltd

License Agreement

Hestor Ltd grants a license to use the enclosed software to the original purchaser. Copies may be made for back-up purposes only.

Copies made for any other purpose are expressly prohibited, and adherence to this requirement is the sole responsibility of the purchaser.

Customer written applications containing embedded Hestor Ltd products may be freely distributed, without royalty payments to Hestor Ltd, provided that such distributed Hestor Ltd product is bound into these applications in such a way so as to prohibit separate use in design mode, and that such Hestor Ltd product is distributed only in conjunction with the customer's own software product. The Hestor Ltd product may not be distributed by itself in any form.

Neither source code for Hestor Ltd products nor modified source code for Hestor Ltd products may be distributed under any circumstances, nor may you distribute .OBJ, .LIB, etc. files that contain our routines. This component may be used as a constituent component only if the compound component thus created is distributed with and as an integral part of an application. Permission to use this component as a constituent component does not grant a right to distribute the license (LIC) file or any other file other than the component executable itself. This license may not be transferred to a third party.

This product is licensed for use by only one developer at a time. Hestor Ltd expressly prohibits installing this product on more than one computer if there is any chance that both copies will be used simultaneously. This restriction also extends to installation on a network server, if more than one workstation will be accessing the product. All developers working on a project that includes a Hestor Ltd product, even though not working directly with the Hestor Ltd , are required to purchase a license for that Hestor Ltd product.

This software is provided "as is". Hestor Ltd makes no warranty, expressed or implied, with regard to the software. All implied warranties, including the warranties of merchantability and fitness for a particular use, are hereby excluded.

Hestor Ltd's LIABILITY IS LIMITED TO THE PURCHASE PRICE. Under no circumstances shall Hestor Ltd or the authors of this product be liable for any incidental or consequential damages, nor for any damages in excess of the original purchase price.

To be eligible for free technical support via the Internet and to ensure that you are notified of any future updates, please complete the enclosed registration card and return it to Hestor Ltd .

English Version

We require that you purchase one copy of a component per developer on a project. If this is met, you may distribute the component with your application royalty free. You may never distribute the LIC file. You may not change the product in any way that removes or changes the requirement of a license file.

We encourage the use of our components as constituent components when the compound components you create are an integral part of your application. But we don't allow distribution of our components as constituents of other components when the compound component is not part of an application. The reason we need to have this restriction is that without it someone might decide to use our component as a constituent, add some trivial (or even non-trivial) enhancements and then sell the compound component. Obviously there would be little difference between that and just plain reselling our component.

If you have purchased the source code, you may not re-distribute the source code either (nor may you copy it into your own project). Hestor Ltd retains the copyright to the source code.

Your license is non transferable. Contact us for further information.

The sample versions of our products are intended for evaluation purposes only. You may not use the sample version to develop completed applications.

If you have any issues with registering your licence code or any other problems please contact us; support@hestor.com


Fancy Fonts Reference

© 2015 Hestor Ltd


Fancy Fonts Overview
Fancy Fonts Reference > Fancy Fonts Overview

Fancy Fonts Overview

We developed Fancy Fonts for our own internal use within our software applications, we have developed many applications over the years.

These range from simple stand alone systems, to systems in use within large organisations including Hospitals, etc.

Fancy Fonts will allow you to place a CAPTION like object on your form, the big difference is that three functions are made instantly available to you;

* Caption's can have a shadow behind it, the shadow going in one of eight different directions,

* Caption's can be flashing between colors at a given speed,

* Caption's can be set so once the user clicks it a web page is opened up in the default browser.

All of which is done by setting a simple property.

* Shadow Color, Shadow Direction, Shadow Enabled, Shadow Width

* Flashing Color, Flashing Enabled

* Html Active, Html Link


Technical / Distribution Information
Fancy Fonts Reference > Technical / Distribution Information

Technical / Distribution Information

Active X Control

Fancy Fonts OCX

FILENAME | Hestor_FancyFonts.Ocx
Object Name | FancyFonts
Object ID | D97CFBAB-11F9-4623-BA81-C04A04D59F80
Compatibility | VB 5.0 and 6.0, VFP 5.0 and 6.0, other languages
DLL's required | None. This is a light ActiveX control that requires no extra DLLs to operate. This means that your installation packages will be smaller. And, your web pages will load faster, since there are no extra DLL's to download
Registration | You will need to register the OCX control within your installation programme.

Distribution Note

When you develop and distribute an application that uses this component:

1. The ActiveX control (Hestor_FancyFonts.ocx) must be included in the installation package.

2. Use RegSvr32.EXE (or any other install package) to register the OCX.

3. Install the component file(s) into the user's Windows SYSTEM32 folder.

The component file(s) has/have version information built into it.

During installation, ensure that you are not overwriting a newer version.

4. DO NOT include the component's .LIC file.


License Key Registration - How to register
Fancy Fonts Reference > License Key Registration - How to register

License Key Registration - How to register

Method 1 - Design Mode

After placing the object onto your Form, press F4 - bring up the property window and enter your

registration details.

Enter in your Company, Licence and User details as they appear in the registration email we

have sent you.

Once entered into the object properties, the NAG screen will not be shown.

Method 2 - Programmatically

You can enter your registration details via coding, this is then processed at run time.

Example Coding (Visual Basic 6)

With FancyFonts1

.Company = "Hestor Ltd"

.Licence = "122-837D-203-72F"

.User = "Davids"

End With

* To complete a registration process, you need to specify the three fields above;

* Company Name, Licence Number & User Name - all of these details are emailed to you upon

successful purchase of a valid licence subscription.

* You can confirm the licence has been successful by calling the Property CallKey, for example;

Dim bSuccess as Boolean

bSuccess = FancyFonts1.CofnrmKey

MsgBox "Key Status (True = Valid, False - Invalid) : " & bSuccess

If you have any problems or issues please contact us via support@hestor.com


NAG Screen - Valid licece details required
Fancy Fonts Reference > NAG Screen - Valid licece details required

NAG Screen - Valid licence details required

Until you have purchased and registered your details, the NAG screen will appear periodically.

Enter in your Company, Licence and User details as they appear in the registration email we have sent you.

Once entered into the object properties, the NAG screen will not be shown either at Design or Run time.

See License Key Registration for further information on how to register your purchase details.

If you have any problems or issues please contact us via support@hestor.com


Tutorials

© 2015 Hestor Ltd


Basic Example (VB)
Tutorials > Basic Example (VB)

Basic Examples

Within the installation folder you will find the Samples folder, under that the Simple folder

Three basic examples are shown there, load them up, run them, then look at the source code.

As developers, we find that the best way for coding is by looking, seeing and following.

These examples cover the basic functionality of the the control;

* Shadow - Caption's can have a shadow behind it, shadow in 1 of 8 directions,

* Flashing - Caption's can be flashing between colors at a given speed,

* Web - Caption's can be set to open a web page in the user's default browser.

These three basic examples will allow you to see the coding, commands and properties in action.

You can add / alter coding to these examples and re-run them, you can also change a lot of the properties in DESIGN time - these are actively shown in DESIGN time.

Try playing with the different examples and the different settings for the properties, you can come up with some amazing examples.

If you need clarification on any of the properties and you can't find the solution within the help guides, please do not hesitate to contact us.


the Shadow example
Tutorials > Basic Example (VB) > the Shadow example

Basic Examples - the Shadow Example

Within the installation folder you will find the Samples folder, under that the Simple folder you will find the sub folder Shadow and in that the project SimpleShadow.vbp

This example allows you to simply point over an arrow and the Caption Luv Shadows will change to show you the shadow effect in the direction the arrow is pointing.

You can also choose the direction from the drop down menu (see below), in addition to that change the ShadowWidth by typing in a value in the text box.

Some amazing effective can be produce by mixing the properties, the choice is endless !

When you look at the FORM is DESIGN mode you can click onto the FancyFonts controls and see all their property settings.


the Flashing example
Tutorials > Basic Example (VB) > the Flashing example

Basic Examples - the Flashing Example

Within the installation folder you will find the Samples folder, under that the Simple folder you will find the sub folder Flashing and in that the project SimpleFlashing.vbp

This example shows you just how cool the FancyFonts object can be, below it you can see the source code.

When you look at the FORM is DESIGN mode you can click onto the FancyFonts controls and see all their property settings.

Double click into the Form_Load, there you can add in any extra properties you want.

You can also see the object change in DESIGN time without the need of coding, try changing the objects properties.


the Web / Html example
Tutorials > Basic Example (VB) > the Web / Html example

Basic Examples - the Web / Html Example

Within the installation folder you will find the Samples folder, under that the Simple folder you will find the sub folder Web and in that the project SimpleWeb.vbp

This example shows you just how simple it is to provide your customers with direct links from within their applications.

You can place active links on any FancyFonts object, all you need to do is set two properties;

1) HtmlActive = True

2) HtmlLink = "http://www.ocx.hestor.com"

That's it, regardless of any other settings of the object, the minute you set the HtmlActive= True, the object becomes alive. As soon as its clicked the users default web browser is opened and directed to the given website.

You can also switch the link off during run time, just simply set the property to FALSE.


Enhanced Example (VB)
Tutorials > Enhanced Example (VB)

Enhanced Examples

Within the installation folder you will find the Samples folder, under that the Enhcanced folder

Two enhanced examples are shown there, load them up, run them, then look at the source code.

As developers, we find that the best way for coding is by looking, seeing and following.

These examples cover how to use the control in multiple combinations;

* All - Caption showing shadow, flashing and HTML link working,

* Multi - Mixture of captions, some flashing, some html links, all different sizes.

These two enhanced examples will allow you to see the coding commands, properties in action.


the All example
Tutorials > Enhanced Example (VB) > the All example

Enhanced Examples - the All Examlpe

Within the installation folder you will find the Samples folder, under that the Enhanced folder you will find the sub folder All and in that the project EnhancedAll.vbp

This example shows a whole host of examples, showing off the Shadow effect, Flashing effect, Edging effect and the HTML link effect.

Try changing various settings, and what the components change in front of you.

You can mix n match any of the effects / features together, so if you want it flashing with a html link or if you want a label with shadow shown and edging around it.


the Multi example
Tutorials > Enhanced Example (VB) > the Multi example

Enhanced Examples - the Multi Examlpe

Within the installation folder you will find the Samples folder, under that the Enhanced folder you will find the sub folder Multi and in that the project EnhancedMulti.vbp

With this example you are able to set the properties for the object, simply point the hand at the relevant Object and then change the objects.

As you change the properties, the object will change. This example really allows you to see what properties are available and what they do.

As you change your properties, if you click the Generate Code button - the system will self generate all the coding required.

You can simply then copy and paste the coding into your application.


Methods

© 2015 Hestor Ltd


About
Methods > About

Displays the About Box.

Syntax

[Visual Basic]

object.About

The syntax of the About method has these parts;

Part | Description
object | Required. A FancyFonts component.

Remarks

This method displays the About Box for the control.


Confirm Key
Methods > Confirm Key

Returns a value to indicate if the current licence key is valid.

Syntax

[Visual Basic]

object.ConfirmKey [=confirmkey]

The syntax of the ConfirmKey property has these parts;

Part | Description
object | A FancyFonts component.
confirmkey | A Boolean expression that determines whether your licence key is valid.

Remarks

Each FancyFonts object requires licence validation, make sure you either set these values into the

objects properties at design time or set them within your coding at run time.

Example Coding (Visual Basic 6)

With FancyFonts1

.Company = "Hestor Ltd"

.User = "Davids"

.License = "239-2398-D34-2817"

End With

Dim TestKey as Boolean

TestKey=FancyFonts1.ConfirmKey

IF TestKey=True then Msgbox "Your Key is VALID" ELSE Msgbox "Sorry Key not accepted"

* Remember that the properties can be entered at design time onto the object itself (Visual Basic 6

- press F4), thus removing the need to manually add the coding above.

Data Type

Boolean


Enabled
Methods > Enabled

Enables or disables the object from running in LIVE mode.

Syntax

[Visual Basic]

object.Enabled [=enabled]

The syntax of the Enabled property has these parts;

Part | Description
object | A FancyFonts component.
enabled | A Boolean expression that determines whether the object is running in LIVE mode.

Remarks

Each FancyFonts object can be shown either running (LIVE - TRUE) or not (PAUSED - FALSE).

The caption will be displayed in accordance with the property settings your have chosen regardless

of this setting.

Data Type

Boolean

Send your comments, suggestions or to ask questions about this component

Copyright 2015 - All Rights Reserved Hestor Ltd

Related Topics:
Enabled
© 2015 Hestor Ltd


Interval
Methods > Interval

Returns or sets the Interval value to be used by the timer on the object

Syntax

[Visual Basic]

object.Interval [=interval]

The syntax of the Interval property has these parts;

Part | Description
object | A FancyFonts component.
interval | A Long number, the minimum is 1,000, the maximum is 60,000

Remarks

Each FancyFonts object can have its own Interval timer set, so one flashing font could be set to flash

quicker than the others.

The interval value is set in 10th of a seconds - so 1,000 is 1 second, 60,000 = 60 seconds.

Example Coding (Visual Basic 6)

With FancyFonts1

.Interval=1000

End With

With FancyFonts2

.Interval=20000

End With

* The above would have the effect of two flashing labels being shown, the first flashing every

1 seconds, the second once only every 20 seconds.

Data Type

Long Integer

Send your comments, suggestions or to ask questions about this component

Copyright 2015 - All Rights Reserved Hestor Ltd

Related Topics:
Interval
© 2015 Hestor Ltd


Properties

© 2015 Hestor Ltd


Alignment
Properties > Alignment

Returns or sets the Alignment of the caption.

Syntax

[Visual Basic]

object.Alignment [= alignment]

The syntax of the Alignment property has these parts;

Part | Description
object | A FancyFonts component.
alignment | The alignment to the used when displaying the objects caption.

Remarks

The value of the alignment property must be one of the following constants;

Constants | Value | Description
vbLeft | 0 | Align the caption to the left hand side of the object
vbRight | 1 | Align the caption to the right hand side of the object
vbCenter | 2 | Align the caption in the middle of the object

Data_Type

Integer


BackColor
Properties > BackColor

Returns or sets the BackColor of the Fancy Fonts control.

Syntax

[Visual Basic]

object.BackColor [= backcolor]

The syntax of the BackColor property has these parts;

Part | Description
object | A FancyFonts component.
backcolor | A color that determines the background color of the FancyFont's object.

Remarks

You can achieve some great looking captions by settings properties such as the BackColor,

BorderStyle, EdgingColor and other properties, see the example coding in the

Samples folders.

Example Coding (Visual Basic 6)

With FancyFonts1

.BackColor= &H8000000F&

.Caption = "Welcome to Fancy Fonts"

.ForeColor = vbRed

.FlashingColor = vbBlue

.FlashingEnabled = True

.Interval = 3000

End With

* In the above example, the object will flash every 3 seconds between RED and BLUE, to stop the

flashing, set the .FlashingEnabled = FALSE (the background color is set to the default

form background color).

Data_Type

OLE_COLOR


BorderStyle
Properties > BorderStyle

Returns or sets the BorderStyle of the caption.

Syntax

[Visual Basic]

object.BorderStyle [= borderstyle ]

The syntax of the BorderStyle property has these parts;

Part | Description
object | A FancyFonts component.
borderstyle | An Integer value

Remarks

The value of the borderstyle property must be one of the following constants;

Constants | Value | Description
None | 0 | No border is shown
Fixed | 1 | A 3D effect border is shown

Remarks

* You can achieve some amazing looking results by mixing the property options, eg; the

BackColor,EdgingColor, FlashingColor, ShadowDirection, etc - Take a look

at the coding examples which are located in the Samples folders.

Data_Type

Integer


Caption
Properties > Caption

Returns / sets a Caption of the control.

Syntax

[Visual Basic]

object.Caption [= caption]

The syntax of the Caption property has these parts;

Part | Description
object | A FancyFonts component.
caption | A String expression that is displayed as the objects caption title.

Remarks

The object caption can be displayed either with / without shadow, with / without flashing,

with / without a HTML Link.

Example Coding (Visual Basic 6)

With FancyFonts1

.Caption = "Welcome to Fancy Fonts"

.FlashingEnabled = False

.ShadowEnabled = False

End With

With FancyFonts2

.Caption = "Welcome to Flashing Fonts"

.FlashingColor = vbRed

.FlashingEnabled = True

.ShadowEnabled = False

End With

With FancyFonts3

.Caption = "Welcome to Fancy Fonts with Shadow"

.FlashingEnabled = False

.ShadowEnabled = True

.ShadowWidth = 3

.ShadowDirection = UpLeft

End With

* As the example above shows, in FancyFonts1 - Just the Caption, FancyConts2 - Red flashing caption

& Fancy Fonts3 - Shadowed Caption with No Flashing.

* You can of course mix any combination you want, remember of course if you set the FlashingColor

to be the same as the ForeColor then NO FLASHING will be visible !

Data Type

String


Company
Properties > Company

Returns / sets your Company details, registered users.

Syntax

[Visual Basic]

object.Company [= company]

The syntax of the Company property has these parts;

Part | Description
object | A FancyFonts component.
company | A String expression that contains your company information as from your registration details.

Remarks

The property company is used as a way of setting your registration details into the system, this

can either be set within the Design Mode or in Run Time.

Example Coding (Visual Basic 6)

With FancyFonts1

.Company = "Hestor Ltd"

.Licence = "122-837D-203-72F"

.User = "Davids"

End With

* To complete a registration process, you need to specify the three fields above;

* Company Name, Licence Number & User Name - all of these details are emailed to you upon

successful purchase of a valid licence subscription.

* You can confirm the licence has been successful by calling the Property CallKey, for example;

Dim bSuccess as Boolean

bSuccess = FancyFonts1.CofnrmKey

MsgBox "Key Status (True = Valid, False - Invalid) : " & bSuccess

Data Type

String


Edging
Properties > Edging

Returns or sets the Edging property, turning on / off the edging of the control.

Syntax

[Visual Basic]

object.Edging [= edging]

The syntax of the Edging property has these parts;

Part | Description
object | A FancyFonts component.
edging | A Boolean expression either being set as TRUE or FALSE

Remarks

* If set to true then the object will have an edging line drawn around it, you can set the color by

using the property EdgingColor.

* Take a look at the Samples included, these are in the folders Samples, these can be very

effective.

Data_Type

Boolean


EdgingColor
Properties > EdgingColor

Returns or sets the EdgningColor of the Fancy Fonts control.

Syntax

[Visual Basic]

object.EdgingColor [= edgingcolor ]

The syntax of the EdgingColor property has these parts;

Part | Description
object | A FancyFonts component.
edgingcolor | The color that determines the edging color of the caption when the edging property is enabled.

Remarks

The object can be set to have an edging around it, you can choose the color of the edging, this can

look very effective.

Example Coding (Visual Basic 6)

With FancyFonts1

.BackColor = &H8000000F&

.BorderStyle = None

.Caption = "Welcome to Fancy Fonts"

.Edging = True

.EdgingColor = VbBlue

.ForeColor = vbRed

.FlashingEnabled = false

End With

* In the above example, the object will display the caption 'Welcome to Fancy Fonts' in red with

the usual grey default background color - the object will have a single edging shown in blue.

Data_Type

OLE_COLOR


Enabled
Properties > Enabled

Returns or sets whether the control is Enabled.

Syntax

[Visual Basic]

object.Enabled [= enabled]

The syntax of the Enabled property has these parts;

Part | Description
object | A FancyFonts component.
enabled | A Boolean expression either being set as TRUE or FALSE

Remarks

* Even though the object may have the Enabled status effect set as FALSE the object will be

shown in accordance with the other properties.

Data_Type

Boolean

Send your comments, suggestions or to ask questions about this component

Copyright 2015 - All Rights Reserved Hestor Ltd

Related Topics:
Enabled
© 2015 Hestor Ltd


Flashing Color
Properties > Flashing Color

Returns or sets the Flashing Color of the Fancy Fonts control.

Syntax

[Visual Basic]

object.FlashingColor [= flashingcolor]

The syntax of the FlashingColor property has these parts;

Part | Description
object | A FancyFonts component.
flashingcolor | The color that determines the foreground color of the caption when flashing is enabled.

Remarks

The object can be set to a single color or set to flash between two colors, the primary color is

the forecolor the secondary is this one - the flashingcolor, this can either be set within

the Design Mode or in Run Time.

Example Coding (Visual Basic 6)

With FancyFonts1

.Caption = "Welcome to Fancy Fonts"

.ForeColor = vbRed

.FlashingColor = vbBlue

.FlashingEnabled = True

.Interval = 3000

End With

* In the above example, the object will flash every 3 seconds between RED and BLUE, to stop

the flashing, set the .FlashingEnabled = FALSE

Data_Type

OLE_COLOR


Flashing Enabled
Properties > Flashing Enabled

Returns or sets the Flashing Enabled property, turning on / off flashing of the control.

Syntax

[Visual Basic]

object.FlashingEnabled [= flashingenabled]

The syntax of the FlashingEnabled property has these parts;

Part | Description
object | A FancyFonts component.
flashingenabled | A Boolean expression either being set as TRUE or FALSE

Remarks

* If set to true then the object will be flashing, this is dependant on other properties being set,

if Visible is set the FALSE then no flashing of the object will occur.

* The shadow background of the object will NOT change color, likewise if the Flashing Color and

ForeColor are the same no flashing will be visible !

Data_Type

Boolean


Font
Properties > Font

Returns or sets the Font of the Fancy Fonts control.

Syntax

[Visual Basic]

object.Font [= font]

The syntax of the Font property has these parts;

Part | Description
object | A FancyFonts component.
font | A Font Object that is used by the FancyFont's control.

Remarks

Use the Font property of an object to identify a specific Font Object whose properties you want

to use, this can either be set within the Design Mode or in Run Time.

Example Coding (Visual Basic 6)

With FancyFonts1

.Caption = "Welcome to Fancy Fonts"

.Font.Name = "Arial"

.Font.Bold = True

.Font.Size = 72

End With

* When the ShadowEnabled = True, the chosen font is automatically displayed, even in Design Mode.

Data_Type

IFontDisp


ForeColor
Properties > ForeColor

Returns or sets the ForeColor of the Fancy Fonts control.

Syntax

[Visual Basic]

object.ForeColor [= forecolor]

The syntax of the ForeColor property has these parts;

Part | Description
object | A FancyFonts component.
forecolor | A color that determines the foreground color of the FancyFont's object.

Remarks

The object can be set to a single color or set to flash between two colors, the primary color is the

forecolor the secondary is this one - the flashingcolor, this can either be set within the

Design Mode or in Run Time.

Example Coding (Visual Basic 6)

With FancyFonts1

.Caption = "Welcome to Fancy Fonts"

.ForeColor = vbRed

.FlashingColor = vbBlue

.FlashingEnabled = True

.Interval = 3000

End With

* In the above example, the object will flash every 3 seconds between RED and BLUE, to stop the flashing,

set the .FlashingEnabled = FALSE

Data_Type

OLE_COLOR


Html Active
Properties > Html Active

Returns / sets the HtmlActive status, when set to TRUE and the user click the Fancy Font's Caption the

users web browser is launched and the linked HTML page is shown.

Syntax

[Visual Basic]

object.HtmlActive [= Enabled ]

The syntax of the HtmlActive property has these parts;

Part | Description
object | A FancyFonts component.
enabled | A Boolean expression either being set as TRUE or FALSE

Remarks

You can automatically make your applications open the users default web browsers and go to

a pre-set website, to make the HTML Link active set this property to True.

Example Coding (Visual Basic 6)

With FancyFonts1

.Caption = "Visit our OCX store now."

.HtmlLink = "http://www.ocx.hestor.com"

.HtmlActive = True

.ToolTextTip = "Click this FancyFont Caption to visit my website."

End With

* In the above example, the object will show the caption Visit our OCX store now,

* When the user hover's over the caption the tool text tip will read

Click this FancyFont Caption to visit my website,

* When the user clicks the object their default web browsers will launch and the preset website

will be visited, in this case our http://www.ocx.hestor.com website.

Data_Type

Boolean


Html Link
Properties > Html Link

Returns or sets the Html Link property of the Fancy Fonts control, this is the website address that is

to be launched via the users default web browser.

Syntax

[Visual Basic]

object.HtmlLink [= string ]

The syntax of the HtmlLink property has these parts;

Part | Description
object | A FancyFonts component.
http link | The http website address that is to be opened once the user's default browser has been launched.

Remarks

You should always use the full http addressing format to ensure that the link / website you

want to show is always shown.

You must also set the HtmlActive property to TRUE is order to make the FancyFont clickable !

Example Coding (Visual Basic 6)

With FancyFonts1

.Caption = "Visit our OCX store now."

.HtmlLink = "http://www.ocx.hestor.com"

.HtmlActive = True

.ToolTextTip = "Click this FancyFont Caption to visit my website."

End With

* In the above example, the object will show the caption Visit our OCX store now,

* When the user hover's over the caption the tool text tip will read

Click this FancyFont Caption to visit my website,

* When the user clicks the object their default web browsers will launch and the preset

website will be visited, in this case our http://www.ocx.hestor.com website.

Data_Type

String


Interval
Properties > Interval

Returns or sets the Interval value to be used by the timer on the object

Syntax

[Visual Basic]

object.Interval [=interval ]

The syntax of the Interval property has these parts;

Part | Description
object | A FancyFonts component.
interval | A Long number, the minimum is 1,000, the maximum is 60,000

Remarks

Each FancyFonts object can have its own Interval timer set, so one flashing font could be set

to flash quicker than the others.

The interval value is set in 10th of a seconds - so 1,000 is 1 second, 60,000 = 60 seconds.

Example Coding (Visual Basic 6)

With FancyFonts1

.Interval=1000

End With

With FancyFonts2

.Interval=20000

End With

* The above would have the effect of two flashing labels being shown, the first flashing every

1 seconds, the second once only every 20 seconds.

Data Type

Long Integer

Send your comments, suggestions or to ask questions about this component

Copyright 2015 - All Rights Reserved Hestor Ltd

Related Topics:
Interval
© 2015 Hestor Ltd


Licence
Properties > Licence

Returns / sets your Licence details, registered users.

Syntax

[Visual Basic]

object.Licence [= licence]

The syntax of the Company property has these parts;

Part | Description
object | A FancyFonts component.
licence | A String expression that contains your licence information as from your registration details.

Remarks

The property licence is used as a way of setting your registration details into the system, this

can either be set within the Design Mode or in Run Time.

Example Coding (Visual Basic 6)

With FancyFonts1

.Company = "Hestor Ltd"

.Licence = "122-837D-203-72F"

.User = "Davids"

End With

* To complete a registration process, you need to specify the three fields above;

* Company Name, Licence Number & User Name - all of these details are emailed to you upon

successful purchase of a valid licence subscription.

* You can confirm the licence has been successful by calling the Property CallKey, for example;

Dim bSuccess as Boolean

bSuccess = FancyFonts1.CofnrmKey

MsgBox "Key Status (True = Valid, False - Invalid) : " & bSuccess

Data Type

String


Shadow Color
Properties > Shadow Color

Returns or sets the ShadowColor of the Fancy Fonts control.

Syntax

[Visual Basic]

object.ShadowColor [= shadowcolor ]

The syntax of the Enabled property has these parts;

Part | Description
object | A FancyFonts component.
shadowcolor | The color that will be used for painting the shadowcolor of the FancyFonts control.

Remarks

* If the shadow background color is the same as the foreground color then the shadow effect

might look strange !

Data_Type

OLE_COLOR


Shadow Direction
Properties > Shadow Direction

Returns or sets the ShadowDirection of the caption.

Syntax

[Visual Basic]

object.ShadowDriection [= shadowdirection ]

The syntax of the ShadowDirection property has these parts;

Part | Description
object | A FancyFonts component.
shadowdirection | The direction of the shadow to be shown behind the caption

Remarks

The value of the shadowdirection property must be one of the following constants;

Constants | Value | Description
Up | 1 | Show the shadow above the base line of the caption object
UpRight | 2 | Show the shadow above and to the right of the caption object
Right | 3 | Show the shadow to the right of the caption object
RightDown | 4 | Show the shadow to the right and down of the caption object
Down | 5 | Show the shadow below the caption object
DownLeft | 6 | Show the shadow below and to the left of the caption object
Left | 7 | Show the shadow to the left of the caption object
LeftUp | 8 | Show the shadow above and to the left of the caption object

Remarks

* The effect of the shadow displayed will be changed dramatically by altering the ShadowWidth

property and direction of the shadow.

Data_Type

Integer


Shadow Enabled
Properties > Shadow Enabled

Returns or sets whether the object's ShadowEnabled.

Syntax

[Visual Basic]

object.ShadowEnabled [=shadowenabled ]

The syntax of the ShadowEnabled property has these parts;

Part | Description
object | A FancyFonts component.
shadowenabled | A Boolean expression either being set as TRUE or FALSE

Remarks

* If set to true then the object will have a shadow displayed around the caption, this is dependant

on other properties being set, such as the ShadowWidth, etc.

* If the shadow background color is the same as the foreground color then the shadow effect might

look strange !

Data_Type

Boolean


Shadow Width
Properties > Shadow Width

Returns or sets the with of the ShadowWidth of the Fancy Fonts control.

Syntax

[Visual Basic]

object.ShadowWidth [=shadowwidth ]

The syntax of the ShadowWidth property has these parts;

Part | Description
object | A FancyFonts component.
shadowwidth | A numeric value, which must be bigger than zero.

Remarks

* You can also use points, eg: 1.2, 3.8 in the width.

Data_Type

Single


User
Properties > User

Returns / sets your User details, registered users.

Syntax

[Visual Basic]

object.User [= user ]

The syntax of the Company property has these parts;

Part | Description
object | A FancyFonts component.
user | A String expression that contains your user information as from your registration details.

Remarks

The proeprty licence is used as a way of setting your registration details into the system, this can

either be set within the Design Mode or in Run Time.

Example Coding (Visual Basic 6)

With FancyFonts1

.Company = "Hestor Ltd"

.Licence = "122-837D-203-72F"

.User = "Davids"

End With

* To complete a registration process, you need to specify the three fields above;

* Company Name, Licence Number & User Name - all of these details are emailed to you upon

successful purchase of a valid licence subscription.

* You can confirm the licence has been successful by calling the Property CallKey, for example;

Dim bSuccess as Boolean

bSuccess = FancyFonts1.CofnrmKey

MsgBox "Key Status (True = Valid, False - Invalid) : " & bSuccess

Data Type

String


FAQ's

© 2015 Hestor Ltd


Does Fancy Fonts work with VB net
FAQ's > Does Fancy Fonts work with VB net

Does Fancy Fonts work with VB.net

We have test the control in as many programming languages as possible, likewise as many different versions of Windows as possible.

If however, you come across an instance where the control wont work with the programming language you are using then please do get in touch with us.

If you need any assistance or wish to ask any questions please email support@hestor.com


I can't stop the NAG Screen from showing
FAQ's > I can't stop the NAG Screen from showing

I can't stop the NAG Screen from showing

We have tested and tested over and over again to ensure that the NAG screen is only ever shown when the control is unlicensed.

As soon as you enter in your registration details the NAG screen will NOT be shown again.

If you are shaving issues with this, follow the example shown in the 'License Key Registration - How to register' listed under the Fancy Fonts Reference section.

If you need any assistance or wish to ask any questions please email support@hestor.com


I need something else can you help ?
FAQ's > I need something else can you help ?

I need something else can you help ?

We have developed many applications over the years, ranging from single programmes to entire automation network solutions for hospitals and the likes.

We have the ability to produce coding that will work with web interfaces, mobile devices, laptops. desktops.

We have produced software for biometric devices, swipe cards, NFC readers, VFD poles and a range of other hardware.

We also have our own DATA Centre capabilities, host our own webservers, dns servers, mail cleaners, etc.

So if you need any assistance or wish to ask any questions please email support@hestor.com


The HTML doesn't work
previous
FAQ's > The HTML doesn't work

The HTML doesn't work

We have had reports of some Anti Virus software and possibly Anti Malware programmes blocked the launching of the user's default web browser.

We suggest that you ensure your application is added to their white list if they have a white list facility.

If you need any assistance or wish to ask any questions please email support@hestor.com