Introduction
next

Quick Border

Copyright 2015 by Hestor Ltd.
All Rights Reserved.
Fancy Fonts is a trademark of Hestor Ltd

We developed Quick Border for our own internal use within our software applications, we have developed many applications over the years.

These range from simple stand alone systems, to systems in use within large organisations including Hospitals, etc.

Quick Border will allow you to drag / drop the QB object on your form, when you do this a border is automatically generated to fit the size you have made the object;

* Choose the background colours

* Choose the border colours, fill colours

* Even set the border size, spacing and inner colours

All of which is done by setting a simple properties.

* BackColor, BorderColor, BorderFillColor

* BorderSize, BorderSpacing, BorderVisible

* Enabled, InnerColor

Send your comments, suggestions or to ask questions about this component

Copyright 2015 - All Rights Reserved Hestor Ltd

© 2015 Hestor Ltd


Updates

Updates

Updates are automatically notified to all developers / registered user.

If you need any assistance or wish to ask any questions please email support@hestor.com


Getting Support

Getting Support

We want to be as helpful as possible. We always want you to come away happy. We realize that we can't make everyone happy (for some reason, our families believe we should be at home sometimes) we will however always help as best we can.

Help With Our Components

If you're having trouble with one of our components, here are a few general suggestions.

First, take a look at the sample programs. Usually, there is a sample program that shows how to

use every feature of our components. These can be quite helpful.

These sample programs are located in the default installation folders eg: c:\program files\hestor\quickborders\Samples

Second, if you haven't already, take a look at the help file and/or manual.

They spell out what each of the Properties, Events, Methods, Objects and Interfaces does.

If you are still having trouble with one of our components, please feel free to contact us to get help.

When you do, make sure that you have as much information about your problem ready as possible.

The more you tell us, the better we can help you.

Help With General Programming

Many people come to us with questions about general programming issues. We would love to help everyone learn to become great programmers, but we simply don't have the time.

We would always suggest that you read books, try by example, take a look at someone else's coding, when buying books try the likes of ebay first, you can save a huge amount on books purchased that have already been used, and as a rule - as any developer will tell you - you only ever need just a chapter from a book - we personally have hundreds and hundreds of books in the office and the vast majority of them are secondhand !

Getting Support

You can receive support for our products from our FAQ, web site or e-mail.

This Help File

This help file is fully searchable. We suggest that you try that first before anything else. By searching in this help file, you'll be searching all of the reference information for this component and all of the FAQ questions and answers.

FAQ

You can find our FAQ at http://www.ocx.hestor.com/Faqs.html

E-Mail

If you cannot find the answer to your question on our web site, you can email us directly at support@hestor.com.


How to Purchase Licenses

© 2015 Hestor Ltd


Online Via Website
How to Purchase Licenses > Online Via Website

Online Via Website

You can purchase a full licence by visiting our website at the following address;

Quick Border's is sold as a single per developer OCX, this means each developer will require their own licence,.

As a good will gesture we will allow each developer to use their licence key for the OCX on both a fixed computer and their own laptop / notebook.

If you have any issues with registering your licence code or any other problems please contact us; support@hestor.com


Email / Telephone Direct
How to Purchase Licenses > Email / Telephone Direct

Email / Telephone Direct

We are always happy to help where ever possibly, you can send any questions or support issues via email to; support@hestor.com

We are based in the United Kingdom, support via telephone is offered between the hours of 9:00am to 5.00pm UK time.

You can call the support line on +44 (0) 161 660 1366


Legal Information

© 2015 Hestor Ltd


Royalty Free License Agreement
Legal Information > Royalty Free License Agreement

Royalty Free Licence Agreement

QuickBorder™ by Hestor Ltd

License Agreement

Hestor Ltd grants a license to use the enclosed software to the original purchaser. Copies may be made for back-up purposes only.

Copies made for any other purpose are expressly prohibited, and adherence to this requirement is the sole responsibility of the purchaser.

Customer written applications containing embedded Hestor Ltd products may be freely distributed, without royalty payments to Hestor Ltd, provided that such distributed Hestor Ltd product is bound into these applications in such a way so as to prohibit separate use in design mode, and that such Hestor Ltd product is distributed only in conjunction with the customer's own software product. The Hestor Ltd product may not be distributed by itself in any form.

Neither source code for Hestor Ltd products nor modified source code for Hestor Ltd products may be distributed under any circumstances, nor may you distribute .OBJ, .LIB, etc. files that contain our routines. This component may be used as a constituent component only if the compound component thus created is distributed with and as an integral part of an application. Permission to use this component as a constituent component does not grant a right to distribute the license (LIC) file or any other file other than the component executable itself. This license may not be transferred to a third party.

This product is licensed for use by only one developer at a time. Hestor Ltd expressly prohibits installing this product on more than one computer if there is any chance that both copies will be used simultaneously. This restriction also extends to installation on a network server, if more than one workstation will be accessing the product. All developers working on a project that includes a Hestor Ltd product, even though not working directly with the Hestor Ltd , are required to purchase a license for that Hestor Ltd product.

This software is provided "as is". Hestor Ltd makes no warranty, expressed or implied, with regard to the software. All implied warranties, including the warranties of merchantability and fitness for a particular use, are hereby excluded.

Hestor Ltd's LIABILITY IS LIMITED TO THE PURCHASE PRICE. Under no circumstances shall Hestor Ltd or the authors of this product be liable for any incidental or consequential damages, nor for any damages in excess of the original purchase price.

To be eligible for free technical support via the Internet and to ensure that you are notified of any future updates, please complete the enclosed registration card and return it to Hestor Ltd .

English Version

We require that you purchase one copy of a component per developer on a project. If this is met, you may distribute the component with your application royalty free. You may never distribute the LIC file. You may not change the product in any way that removes or changes the requirement of a license file.

We encourage the use of our components as constituent components when the compound components you create are an integral part of your application. But we don't allow distribution of our components as constituents of other components when the compound component is not part of an application. The reason we need to have this restriction is that without it someone might decide to use our component as a constituent, add some trivial (or even non-trivial) enhancements and then sell the compound component. Obviously there would be little difference between that and just plain reselling our component.

If you have purchased the source code, you may not re-distribute the source code either (nor may you copy it into your own project). Hestor Ltd retains the copyright to the source code.

Your license is non transferable. Contact us for further information.

The sample versions of our products are intended for evaluation purposes only. You may not use the sample version to develop completed applications.

If you have any issues with registering your licence code or any other problems please contact us; support@hestor.com


Quick Border Reference

© 2015 Hestor Ltd


Quick Border Overview
Quick Border Reference > Quick Border Overview

Quick Border's Overview

We developed QuickBorder for our own internal use within our software applications, we have developed many applications over the years.

These range from simple stand alone systems, to systems in use within large organisations including Hospitals, etc.

QuickBorder's will allow you to create a complete border just by dropping the object on the form in design mode and the sizing it to your requirement.

* You can Set the Size of the Borders shown

* Set all the different colours; Background, Border, Fill Color, Inner Color

* Just by changing the spacing the entire panel can look completely different, take a look at the samples.

All of which is done by setting a simple property.

* Backcolor, BorderColor, BorderFillColor,

* BorderSize, BorderSpacing, BorderVisible,

* Endabled, InnerColor


Technical / Distribution Information
Quick Border Reference > Technical / Distribution Information

Technical / Distribution Information

Active X Control

Fancy Fonts OCX

FILENAME | Hestor_QuickBorder.Ocx
Object Name | QuickBorder
Object ID | EE2604CF-54E2-4330-AC9A-D2495D4A748B
Compatibility | VB 5.0 and 6.0, VFP 5.0 and 6.0, other languages
DLL's required | None. This is a light ActiveX control that requires no extra DLLs to operate. This means that your installation packages will be smaller. And, your web pages will load faster, since there are no extra DLL's to download
Registration | You will need to register the OCX control within your installation programme.

Distribution Note

When you develop and distribute an application that uses this component:

1. The ActiveX control (Hestor_FancyFonts.ocx) must be included in the installation package.

2. Use RegSvr32.EXE (or any other install package) to register the OCX.

3. Install the component file(s) into the user's Windows SYSTEM32 folder.

The component file(s) has/have version information built into it.

During installation, ensure that you are not overwriting a newer version.

4. DO NOT include the component's .LIC file.


License Key Registration - How to register
Quick Border Reference > License Key Registration - How to register

License Key Registration - How to register

Method 1 - Design Mode

After placing the object onto your Form, press F4 - bring up the property window and enter your

registration details.

Enter in your Company, Licence and User details as they appear in the registration email we

have sent you.

Once entered into the object properties, the NAG screen will not be shown.

Method 2 - Programmatically

You can enter your registration details via coding, this is then processed at run time.

Example Coding (Visual Basic 6)

With QuickBorder1

.Company = "Hestor Ltd"

.Licence = "122-837D-203-72F"

.User = "Davids"

End With

* To complete a registration process, you need to specify the three fields above;

* Company Name, Licence Number & User Name - all of these details are emailed to you upon

successful purchase of a valid licence subscription.

* You can confirm the licence has been successful by calling the Property CallKey, for example;

Dim bSuccess as Boolean

bSuccess = QuickBorder.CofnrmKey

MsgBox "Key Status (True = Valid, False - Invalid) : " & bSuccess

If you have any problems or issues please contact us via support@hestor.com


NAG Screen - Valid licece details required
Quick Border Reference > NAG Screen - Valid licece details required

NAG Screen - Valid licence details required

Until you have purchased and registered your details, the NAG screen will appear periodically.

Enter in your Company, Licence and User details as they appear in the registration email we have sent you.

Once entered into the object properties, the NAG screen will not be shown either at Design or Run time.

See License Key Registration for further information on how to register your purchase details.

If you have any problems or issues please contact us via support@hestor.com


Tutorials

© 2015 Hestor Ltd


Basic Example (VB)
Tutorials > Basic Example (VB)

Basic Examples

Within the installation folder you will find the Samples folder, this contains sample application.

Load up the example and run it, you can see the borders are all different shapes, sizes and colours.

As developers, we find that the best way for coding is by looking, seeing and following.

You can see that the border can not only be different sizes but can also have different spacing settings.

* Colours - Various colours can be set, background, border, border fill & inner fill

* Spacing - You can set the spacing sized used by the border object.

* BorderVisible - Turn on / off the outer edge border to achieve yet another look.

You can add / alter coding to these examples and re-run them, you can also change a lot of the properties in DESIGN time - these are actively shown in DESIGN time.

Try playing with the different examples and the different settings for the properties, you can come up with some amazing examples.

If you need clarification on any of the properties and you can't find the solution within the help guides, please do not hesitate to contact us.


Samples - Various
Tutorials > Basic Example (VB) > Samples - Various

Basic Examples - the Example

Within the installation folder you will find the Samples folder, you will find the Example project

So as you can see, the one object can create a whole range of panels, you can simply add other objects onto the QuickBorder object.

In design time, click onto an object and change the settings, as you do this the object will refresh.

Some amazing effective can be produce by mixing the properties, the choice is endless !


Methods

© 2015 Hestor Ltd


About
Methods > About

Displays the About Box.

Syntax

[Visual Basic]

object.About

The syntax of the About method has these parts;

Part | Description
object | Required. A QuicBorder component.

Remarks

This method displays the About Box for the control.


Confirm Key
Methods > Confirm Key

Returns a value to indicate if the current licence key is valid.

Syntax

[Visual Basic]

object.ConfirmKey [=confirmkey]

The syntax of the ConfirmKey property has these parts;

Part | Description
object | A QuicBorder component.
confirmkey | A Boolean expression that determines whether your licence key is valid.

Remarks

Each QuicBorder object requires licence validation, make sure you either set these values into the

objects properties at design time or set them within your coding at run time.

Example Coding (Visual Basic 6)

With QuickBorder1

.Company = "Hestor Ltd"

.User = "Davids"

.License = "239-2398-D34-2817"

End With

Dim TestKey as Boolean

TestKey=QuickBorder1.ConfirmKey

IF TestKey=True then Msgbox "Your Key is VALID" ELSE Msgbox "Sorry Key not accepted"

* Remember that the properties can be entered at design time onto the object itself (Visual Basic 6

- press F4), thus removing the need to manually add the coding above.

Data Type

Boolean


Enabled
Methods > Enabled

Enables or disables the object from running in LIVE mode.

Syntax

[Visual Basic]

object.Enabled [=enabled]

The syntax of the Enabled property has these parts;

Part | Description
object | A QuickBorder component.
enabled | A Boolean expression that determines whether the object is running in LIVE mode.

Remarks

Each QuickBorder object can be shown either running (LIVE - TRUE) or not (PAUSED - FALSE).

The caption will be displayed in accordance with the property settings your have chosen regardless

of this setting.

Data Type

Boolean


Properties

© 2015 Hestor Ltd


BackColor
Properties > BackColor

Returns or sets the BackColor of the QuickBorder control.

Syntax

[Visual Basic]

object.BackColor [= backcolor]

The syntax of the BackColor property has these parts;

Part | Description
object | A QuickBorder component.
backcolor | A color that determines the background color of the QuickBorder's object.

Remarks

You can achieve some great looking borders by settings properties such as the BackColor,

BorderColor, BorderFillColor, InnerColor and other properties, see the example coding in the

Samples folders.

Example Coding (Visual Basic 6)

With QuickBorder1

.BackColor= &H8000000F&

.BorderColor=vbGreen

.BorderFillColor=vbYellow

.ForeColor = vbRed

.InnerColor= vbBlue

.Visible= True

End With

* In the above example, the object will have a green outer border, a yellow filling color,

Red foreground and the Inner colour will be set to Blue.

Data_Type

OLE_COLOR


BorderColor
Properties > BorderColor

Returns or sets the BorderColor of the Quick Border control.

Syntax

[Visual Basic]

object.BorderColor [= bordercolor]

The syntax of the BorderColor property has these parts;

Part | Description
object | A QuickBorder component.
backcolor | A color that determines the border color of the QuickBorder's object.

Remarks

You can achieve some great looking borders by settings properties such as the BackColor,

BorderColor, BorderFillColor, InnerColor and other properties, see the example coding in the

Samples folders.

Example Coding (Visual Basic 6)

With QuickBorder1

.BackColor= &H8000000F&

.BorderColor=vbGreen

.BorderFillColor=vbYellow

.ForeColor = vbRed

.InnerColor= vbBlue

.Visible= True

End With

* In the above example, the object will have a green outer border, a yellow filling color,

Red foreground and the Inner colour will be set to Blue.

Data_Type

OLE_COLOR


BorderFillColor
Properties > BorderFillColor

Returns or sets the BorderFillColor of the QuickBorder control.

Syntax

[Visual Basic]

object.BorderFillColor [= borderfillcolor]

The syntax of the BorderFillColor property has these parts;

Part | Description
object | A QuickBorder component.
backcolor | A color that determines the border fill color of the QuickBorder's object.

Remarks

You can achieve some great looking borders by settings properties such as the BackColor,

BorderColor, BorderFillColor, InnerColor and other properties, see the example coding in the

Samples folders.

Example Coding (Visual Basic 6)

With QuickBorder1

.BackColor= &H8000000F&

.BorderColor=vbGreen

.BorderFillColor=vbYellow

.ForeColor = vbRed

.InnerColor= vbBlue

.Visible= True

End With

* In the above example, the object will have a green outer border, a yellow filling color,

Red foreground and the Inner colour will be set to Blue.

Data_Type

OLE_COLOR


Company
Properties > Company

Returns / sets your Company details, registered users.

Syntax

[Visual Basic]

object.Company [= company]

The syntax of the Company property has these parts;

Part | Description
object | A QuickBorder's component.
company | A String expression that contains your company information as from your registration details.

Remarks

The property company is used as a way of setting your registration details into the system, this

can either be set within the Design Mode or in Run Time.

Example Coding (Visual Basic 6)

With QuickBorder1

.Company = "Hestor Ltd"

.Licence = "122-837D-203-72F"

.User = "Davids"

End With

* To complete a registration process, you need to specify the three fields above;

* Company Name, Licence Number & User Name - all of these details are emailed to you upon

successful purchase of a valid licence subscription.

* You can confirm the licence has been successful by calling the Property CallKey, for example;

Dim bSuccess as Boolean

bSuccess = QuickBorder1.CofnrmKey

MsgBox "Key Status (True = Valid, False - Invalid) : " & bSuccess

Data Type

String


BorderSize
Properties > BorderSize

Returns or sets the BorderSize property, changing the appearance of the width of the overall border

Syntax

[Visual Basic]

object.BorderSize [= bordersize]

The syntax of the BorderSize property has these parts;

Part | Description
object | A QuickBorder's component.
BorderSize | An integer value indicating the size of the border.

Remarks

* If set to true then the object will have an edging line drawn around it, you can set the color by

using the properties Backcolor, BorderColor, BorderFillColor, InnerColor

* Take a look at the Samples included, these are in the folders Samples, these can be very

effective.

Data_Type

Integer


BorderSpacing
Properties > BorderSpacing

Returns or sets the BorderSpacing of the Quick Border control.

Syntax

[Visual Basic]

object.BorderSpacing [= borderspacing]

The syntax of the BorderSpacing property has these parts;

Part | Description
object | A QuickBorder's component.
borderspacing | An integer value changing the spacing shown within each part of the border

Remarks

As you change the border spacing you will see your object change, play around with this to you get the look you want.

Example Coding (Visual Basic 6)

With QuickBorder1

.BackColor= &H8000000F&

.BorderColor=vbGreen

.BorderFillColor=vbYellow

.BorderSize=200

.ForeColor = vbRed

.InnerColor= vbBlue

.Visible= True

End With

Data_Type

Integer


Enabled
Properties > Enabled

Returns or sets whether the control is Enabled.

Syntax

[Visual Basic]

object.Enabled [= enabled]

The syntax of the Enabled property has these parts;

Part | Description
object | A QuickBorders component.
enabled | A Boolean expression either being set as TRUE or FALSE

Remarks

* Even though the object may have the Enabled status effect set as FALSE the object will be

shown in accordance with the other properties.

Data_Type

Boolean


Flashing Color
Properties > Flashing Color

Returns or sets the Inner Color of the Quick Border's control.

Syntax

[Visual Basic]

object.InnerColor [= innercolor]

The syntax of the InnerColor property has these parts;

Part | Description
object | A QuickBorder's component.
innercolor | The color that determines the inner color of the border.

Remarks

The object can be set to a single color or set to flash between two colors, the primary color is

the forecolor the secondary is this one - the flashingcolor, this can either be set within

the Design Mode or in Run Time.

Example Coding (Visual Basic 6)

With FancyFonts1

.Caption = "Welcome to Fancy Fonts"

.ForeColor = vbRed

.FlashingColor = vbBlue

.FlashingEnabled = True

.Interval = 3000

End With

* In the above example, the object will flash every 3 seconds between RED and BLUE, to stop

the flashing, set the .FlashingEnabled = FALSE

Data_Type

OLE_COLOR


BorderVisible
Properties > BorderVisible

Returns or sets the Flashing Enabled property, turning on / off flashing of the control.

Syntax

[Visual Basic]

object.FlashingEnabled [= flashingenabled]

The syntax of the FlashingEnabled property has these parts;

Part | Description
object | A FancyFonts component.
flashingenabled | A Boolean expression either being set as TRUE or FALSE

Remarks

* If set to true then the object will be flashing, this is dependant on other properties being set,

if Visible is set the FALSE then no flashing of the object will occur.

* The shadow background of the object will NOT change color, likewise if the Flashing Color and

ForeColor are the same no flashing will be visible !

Data_Type

Boolean


InnerColor
Properties > InnerColor

Returns or sets the Font of the Fancy Fonts control.

Syntax

[Visual Basic]

object.Font [= font]

The syntax of the Font property has these parts;

Part | Description
object | A FancyFonts component.
font | A Font Object that is used by the FancyFont's control.

Remarks

You can achieve some great looking borders by settings properties such as the BackColor,

BorderColor, BorderFillColor, InnerColor and other properties, see the example coding in the

Samples folders.

Example Coding (Visual Basic 6)

Example Coding (Visual Basic 6)

With QuickBorder1

.BackColor= &H8000000F&

.BorderColor=vbGreen

.BorderFillColor=vbYellow

.ForeColor = vbRed

.InnerColor= vbBlue

.Visible= True

End With

* In the above example, the object will have a green outer border, a yellow filling color,

Red foreground and the Inner colour will be set to Blue.

Data_Type

IFontDisp


Licence
Properties > Licence

Returns / sets your Licence details, registered users.

Syntax

[Visual Basic]

object.Licence [= licence]

The syntax of the Company property has these parts;

Part | Description
object | A Quick Border component.
licence | A String expression that contains your licence information as from your registration details.

Remarks

The property licence is used as a way of setting your registration details into the system, this

can either be set within the Design Mode or in Run Time.

Example Coding (Visual Basic 6)

With QuickBorder1

.Company = "Hestor Ltd"

.Licence = "122-837D-203-72F"

.User = "Davids"

End With

* To complete a registration process, you need to specify the three fields above;

* Company Name, Licence Number & User Name - all of these details are emailed to you upon

successful purchase of a valid licence subscription.

* You can confirm the licence has been successful by calling the Property CallKey, for example;

Dim bSuccess as Boolean

bSuccess = QuickBorder.CofnrmKey

MsgBox "Key Status (True = Valid, False - Invalid) : " & bSuccess

Data Type

String


User
Properties > User

Returns / sets your User details, registered users.

Syntax

[Visual Basic]

object.User [= user ]

The syntax of the Company property has these parts;

Part | Description
object | A Quick Border component.
user | A String expression that contains your user information as from your registration details.

Remarks

The proeprty licence is used as a way of setting your registration details into the system, this can

either be set within the Design Mode or in Run Time.

Example Coding (Visual Basic 6)

With QuickBorder1

.Company = "Hestor Ltd"

.Licence = "122-837D-203-72F"

.User = "Davids"

End With

* To complete a registration process, you need to specify the three fields above;

* Company Name, Licence Number & User Name - all of these details are emailed to you upon

successful purchase of a valid licence subscription.

* You can confirm the licence has been successful by calling the Property CallKey, for example;

Dim bSuccess as Boolean

bSuccess = QuickBorder1.CofnrmKey

MsgBox "Key Status (True = Valid, False - Invalid) : " & bSuccess

Data Type

String


FAQ's

© 2015 Hestor Ltd


Does Quick Border work with VB net
FAQ's > Does Quick Border work with VB net

Does Quick Border work with VB.net

We have test the control in as many programming languages as possible, likewise as many different versions of Windows as possible.

If however, you come across an instance where the control wont work with the programming language you are using then please do get in touch with us.

If you need any assistance or wish to ask any questions please email support@hestor.com


I can't stop the NAG Screen from showing
FAQ's > I can't stop the NAG Screen from showing

I can't stop the NAG Screen from showing

We have tested and tested over and over again to ensure that the NAG screen is only ever shown when the control is unlicensed.

As soon as you enter in your registration details the NAG screen will NOT be shown again.

If you are shaving issues with this, follow the example shown in the 'License Key Registration - How to register' listed under the Fancy Fonts Reference section.

If you need any assistance or wish to ask any questions please email support@hestor.com


I need something else can you help ?
FAQ's > I need something else can you help ?

I need something else can you help ?

We have developed many applications over the years, ranging from single programmes to entire automation network solutions for hospitals and the likes.

We have the ability to produce coding that will work with web interfaces, mobile devices, laptops. desktops.

We have produced software for biometric devices, swipe cards, NFC readers, VFD poles and a range of other hardware.

We also have our own DATA Centre capabilities, host our own webservers, dns servers, mail cleaners, etc.

So if you need any assistance or wish to ask any questions please email support@hestor.com


The HTML doesn't work
previous
FAQ's > The HTML doesn't work

The HTML doesn't work

We have had reports of some Anti Virus software and possibly Anti Malware programmes blocked the launching of the user's default web browser.

We suggest that you ensure your application is added to their white list if they have a white list facility.

If you need any assistance or wish to ask any questions please email support@hestor.com